Tacho Still Sluggish

General forum on troubleshooting electrical problems and modifications to electrical systems

Moderator: rztom

Post Reply
Message
Author
Matty
- - - - -
- - - - -
Posts: 340
Joined: Mon Dec 26, 2005 1:13 am
Location: Melbourne Australia

Tacho Still Sluggish

#1 Post by Matty » Tue Dec 30, 2014 7:37 pm

Has anyone come up with a definitive reason why the RZ tacho can become sluggish? Over the years this has been commented on and suggestions that were put forward were a low battery and that a charged battery and/or a decent ride it would un-gum it.

Due to my swingarm conversion and the lack of room, I had been using a 2Ah battery and put the tacho problem down to the small battery but I have recently added a 3Ah battery to be closer to the original battery's capacity and after a 300 Km ride the tacho hasn't improved.

Any thoughts?
I'm not a complete idiot...some parts are missing.

rd84
- - - - -
- - - - -
Posts: 1429
Joined: Thu Nov 17, 2005 7:12 am
Location: Leicestershire, UK

Re: Tacho Still Sluggish

#2 Post by rd84 » Wed Dec 31, 2014 3:58 pm

Always a low battery output for me - charging the battery has cured it every time so far.

Cheers
Paul

Matty
- - - - -
- - - - -
Posts: 340
Joined: Mon Dec 26, 2005 1:13 am
Location: Melbourne Australia

Re: Tacho Still Sluggish

#3 Post by Matty » Sat Jan 12, 2019 6:32 pm

Reviving an old thread.
I've never overcome this issue. I have recently converted the RZ back to stock and have fitted a new, fully charged, standard 5.5Ah battery but the problem with the tacho persists.
where do I look for fault finding.
I'm not a complete idiot...some parts are missing.

User avatar
tacky1
Posts: 666
Joined: Mon Sep 14, 2015 12:30 pm
Location: Bay Area. CA.

Re: Tacho Still Sluggish

#4 Post by tacky1 » Sat Jan 12, 2019 10:33 pm

Did you try a different tacho... I would start there first

Have you always had this problem, Its not a FZ/FZR tacho by any chance

Matty
- - - - -
- - - - -
Posts: 340
Joined: Mon Dec 26, 2005 1:13 am
Location: Melbourne Australia

Re: Tacho Still Sluggish

#5 Post by Matty » Mon Jan 14, 2019 6:17 am

It's the original RZ tacho, I've had the bike 18 years and it used to work fine.
I'm not a complete idiot...some parts are missing.

User avatar
Mike Cichetti
- - - - -
- - - - -
Posts: 343
Joined: Sat Nov 19, 2005 5:58 pm
Location: Pa

Re: Tacho Still Sluggish

#6 Post by Mike Cichetti » Mon Jan 14, 2019 10:56 am

Has it been sitting a long time? I’ve experienced that a after a few rides the tachs began reading normal.

User avatar
silverstrom
- - - - -
- - - - -
Posts: 2652
Joined: Sat Feb 04, 2012 7:36 am
Location: Eastern Ontario Canada

Re: Tacho Still Sluggish

#7 Post by silverstrom » Mon Jan 14, 2019 8:50 pm

They do fail, but typically work or don't. I've opened many and hard failures are usually due to a melted circuit internally.

As mentioned a weak battery will affect the tachometer reading. Seen it here many times. Bikes left sitting for long periods can experience sluggish tachometers, but in most cases a good hard run will see things go back to normal.

For fault finding, start by checking the wiring and making sure it is clean and corrosion free. The 3 contacts at the rear of the tachometer...remove the screws and wire brush the wires and screws. The tach harness will also have a solid grey wire that comes from the CDI. It is a bullet connector. Pull it apart and clean it well. That is where your tach signal comes from. Any issue there and you'll have problems.

I've found loads of insects and spider webs inside tachometers. If you still have problems open the tack and have a look inside. Give it all a good clean. If problems persist you'll need a replacement tachometer.
1985 RZ500 1GE Spec
1985 RZ500 47X Spec Project Bike
1986 RG500 ATR
1986 NS400R
1987 TZR250
1988 Honda RC31
1990 TDR250 Pre-Production # 000001
2007 DL650 VStrom
2014 Triumph Thruxton Modified

Matty
- - - - -
- - - - -
Posts: 340
Joined: Mon Dec 26, 2005 1:13 am
Location: Melbourne Australia

Re: Tacho Still Sluggish

#8 Post by Matty » Tue Jan 15, 2019 4:35 am

Thanks for all the advice, will look into it.
I'm not a complete idiot...some parts are missing.

User avatar
silverstrom
- - - - -
- - - - -
Posts: 2652
Joined: Sat Feb 04, 2012 7:36 am
Location: Eastern Ontario Canada

Re: Tacho Still Sluggish

#9 Post by silverstrom » Tue Jan 15, 2019 11:44 pm

If you need to find one and can't locate one with an RZ500/RD500 search you can also look at RZ350 (1985+ in Australia) and TZR250 (first Gen 2ME/2MY). I have some here but am currently building complete clock sets.
1985 RZ500 1GE Spec
1985 RZ500 47X Spec Project Bike
1986 RG500 ATR
1986 NS400R
1987 TZR250
1988 Honda RC31
1990 TDR250 Pre-Production # 000001
2007 DL650 VStrom
2014 Triumph Thruxton Modified

Post Reply