rev counter not responding to revs

General forum on troubleshooting electrical problems and modifications to electrical systems

Moderator: rztom

Post Reply
Message
Author
RichardUK500
Posts: 15
Joined: Tue Sep 12, 2017 3:24 pm

rev counter not responding to revs

#1 Post by RichardUK500 » Thu Dec 28, 2017 2:51 pm

Thanks in advance to any help with fixing my rev counter....

After the engine is running, its a few minutes before the rev counter starts to work. Firstly it only shows around 1,500rpm. After a short ride it will only register up to 4,000rpm even if I am way higher than that.

Any advice on what could be wrong? I have tried a different rev counter and its just the same.

User avatar
silverstrom
- - - - -
- - - - -
Posts: 2656
Joined: Sat Feb 04, 2012 7:36 am
Location: Eastern Ontario Canada

Re: rev counter not responding to revs

#2 Post by silverstrom » Thu Dec 28, 2017 3:20 pm

Try cleaning the electrical connectors at both ends of the tachometer harness, including the grey bullet connector at the end of the tachometer harness. That grey wire is from the CDI.

Tachometers that have not been used for a long while can be sticky and will often start working properly after a good high RPM engine run. The fact that you have 2 tachometers doing exactly the same thing suggests sticking isn't the problem.

You do have 2 stroke rev counters?
1985 RZ500 1GE Spec
1985 RZ500 47X Spec Project Bike
1986 RG500 ATR
1986 NS400R
1987 TZR250
1988 Honda RC31
1990 TDR250 Pre-Production # 000001
2007 DL650 VStrom
2014 Triumph Thruxton Modified

Post Reply