500 Two-Stroke Tech

500cc GP-Replica Tech Forums

Search  FAQ  Register Login
It is currently Sun Jun 24, 2018 8:04 am

All times are UTC - 4 hours [ DST ]




Post new topic Reply to topic  [ 24 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Wed Feb 21, 2018 5:37 pm 
Offline

Joined: Thu Mar 09, 2006 12:54 pm
Posts: 238
Location: Germany
Yeah, you mentioned that all single components work, so there is only the pickup mount position and the wiring harness (incl. ignition switch).

In the latter one the kill switch grounds the red cable from the source coils.
If you physically disconnect the kill switch and the ignition switch, it cannot be goundeed anywhere. Try if it starts then.
As a counterprobe you can measure resistance against ground on the red/white cable on either the CDI or stator connector (both work).
If the kill switch is set to off, it should go to around zero (before it should be at a high value in the megaohm range) . Same for turning the key to off position.

_________________
Bye
Martin


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Tue Feb 27, 2018 6:03 pm 
Offline

Joined: Thu Feb 15, 2018 4:58 pm
Posts: 7
Just an update guys

after admitting defeat the bike was sent to an auto electrician this week early reports back are the generator is not producing enough power for the spark. I cannot understand this as the generator and flywheel work on another bike.
I will keep you posted
thanks


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Tue Feb 27, 2018 10:44 pm 
Offline
- - - - -
- - - - -
User avatar

Joined: Sat Feb 04, 2012 7:36 am
Posts: 2439
Location: Eastern Ontario Canada
stevig2003 wrote:
I cannot understand this as the generator and flywheel work on another bike.


They work or they don't. They test serviceable or they don't. If they worked on one bike they should work on another. If they don't work on your bike now you have a wiring problem. Just my 2 cents worth.

_________________
1985 RZ500
1985 RZ500 Project Bike
1986 RG500 ATR
1986 NS400R
1987 TZR250
1988 Honda RC31
2007 DL650 VStrom
2014 Triumph Thruxton Modified


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Sat Mar 03, 2018 8:38 am 
Offline

Joined: Thu Mar 09, 2006 12:54 pm
Posts: 238
Location: Germany
As you asked about signal forms and amplitudes:
I had these on my HDD (both from RD350YPVS).
The tach signal is equal to the RD500 and I strongly assume the PickUp should be, too.

Oszilloscope signals of running engine:
Attachment:
Oszilloskop_Signale_RD350YPVS.jpg
Oszilloskop_Signale_RD350YPVS.jpg [ 38.92 KiB | Viewed 757 times ]


Pick-Up has some 7 V Amplitude, Tach 150-170 V

Pickup Signal; Engine spun by hand:
Attachment:
pickup_signal_klein.jpg
pickup_signal_klein.jpg [ 109.59 KiB | Viewed 757 times ]


Pick-Up has some 1.2 V Amplitude

_________________
Bye
Martin


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Thu Mar 08, 2018 2:27 pm 
Offline

Joined: Wed Dec 30, 2015 2:10 pm
Posts: 15
Location: Exmouth devon
Hi guys ive got exactly the same problem with my 500 been trying to get a spark for months. Only thing i havent changed is the pickup Ive moved it closer to flywheel to no avail. Has anyone bought one from a aftermarket outlet and adapted it to fit. ?


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Fri Mar 09, 2018 6:22 pm 
Offline

Joined: Thu Feb 15, 2018 4:58 pm
Posts: 7
AT LAST A SPARK..

Well guys after a few weeks of scratching my head I have finally got a spark.
I still have not managed to get an Oscilloscope but I managed to get a better multi meter.

I have gone through all the harness again after the generator was sent away for repair on the advice of a local bike shop. When we got the exchanged generator back all of the resistance readings were the same as the old one. A note in the package saying ours was ok please try this one !
put it on the bike and once again no spark ...

I measured the voltage out of the cdi on the orange wires to frame earth and was getting 3.2 volts ( not enough to spark) I then cut the cdi earth (black wire) which was measuring 0.01 ohms to frame earth) and measured direct between orange and black out of the cdi 18.5 volts. it looks like I had a fault on the cdi earth circuit under load.

When I connected the black wire out of the cdi onto the coil I now have a spark. I think one of the first posts on this thread mentioned the clump of black wires I did check this first and all earth point were reading under 1 ohm of resistance.


One quick tip for any basic electrical guys needing to fault find a simple LED connected across the pulse wires from the generator ( white/green and white/red ) will give you some indication if you are actually getting a pulse.
if it does not work try changing the wires around because the LED only works one way.
you can also check the orange and black wire with this method out of the cdi it wont tell you if the voltage is correct but will flash to tell you the circuit is working.

thanks again guys for all the help


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Fri Mar 09, 2018 6:30 pm 
Offline

Joined: Thu Feb 15, 2018 4:58 pm
Posts: 7
Webs wrote:
Hi guys ive got exactly the same problem with my 500 been trying to get a spark for months. Only thing i havent changed is the pickup Ive moved it closer to flywheel to no avail. Has anyone bought one from a aftermarket outlet and adapted it to fit. ?



We bought a second hand standard one from Germany in our fault finding it might be going spare
I will ask the owner if he would like to sell it.

You can test with a simple LED if you suspect its not working


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Tue Mar 13, 2018 7:48 pm 
Offline

Joined: Wed Dec 30, 2015 2:10 pm
Posts: 15
Location: Exmouth devon
stevig2003 wrote:
Webs wrote:
Hi guys ive got exactly the same problem with my 500 been trying to get a spark for months. Only thing i havent changed is the pickup Ive moved it closer to flywheel to no avail. Has anyone bought one from a aftermarket outlet and adapted it to fit. ?



We bought a second hand standard one from Germany in our fault finding it might be going spare
I will ask the owner if he would like to sell it.

You can test with a simple LED if you suspect its not working


Top
 Profile  
Reply with quote  
 Post subject: Re: 84 yamaha rd 500 no spark .
PostPosted: Sat Mar 24, 2018 8:30 am 
Offline

Joined: Thu Mar 09, 2006 12:54 pm
Posts: 238
Location: Germany
For completeness sake here's my EFI RZ 350 pick up signal.
In idle it's short under 10V.
I'm using an aftermarket pickup from Ignitech.


Attachments:
IMG_20180324_122709.jpg
IMG_20180324_122709.jpg [ 201.91 KiB | Viewed 439 times ]

_________________
Bye
Martin
Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 24 posts ]  Go to page Previous  1, 2

All times are UTC - 4 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group