Speedo

Need a special, hard-to-find part? Ask for it here!

Moderator: rztom

Post Reply
Message
Author
cainpole
- - - - -
- - - - -
Posts: 56
Joined: Sat Dec 26, 2009 5:20 pm
Location: leesburg ga

Speedo

#1 Post by cainpole » Thu May 10, 2018 5:30 pm

Does anyone have a good speedo for Canadian rz500? Mine pegs the needle after 50mph.

User avatar
silverstrom
- - - - -
- - - - -
Posts: 2659
Joined: Sat Feb 04, 2012 7:36 am
Location: Eastern Ontario Canada

Re: Speedo

#2 Post by silverstrom » Thu May 10, 2018 6:19 pm

Is that a recent development? Are you sure it's the speedo and not your drive gear or cable?

Speedos are gear driven internally and it is very unusual for that kind of problem to occur. I've opened many and found all sorts of insects inside them, with spiders being most common. You can try blasting the inside with air to see if that helps. Pull the lights and any caps on the back to do that. If that doesn't work and as a last resort you can shoot a little light oil inside. Be gentle and keep it below the dial. You can use a drill (in reverse) to drive the speedo to get things moving freely.
1985 RZ500 1GE Spec
1985 RZ500 47X Spec Project Bike
1986 RG500 ATR
1986 NS400R
1987 TZR250
1988 Honda RC31
1990 TDR250 Pre-Production # 000001
2007 DL650 VStrom
2014 Triumph Thruxton Modified

cainpole
- - - - -
- - - - -
Posts: 56
Joined: Sat Dec 26, 2009 5:20 pm
Location: leesburg ga

Re: Speedo

#3 Post by cainpole » Sun May 13, 2018 5:40 pm

Will give a try, but in case that does not fix it, does anyone have a spare?

Post Reply